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Overview of Enhancements in GibbsCAM 14 
The theme of GibbsCAM 14 is: Making the Possible Simple. 

Four new product options: 

• Additive Machining and Additive 5-Axis.  

See   Beta Additive Machining on page 5.  

• Opticam Wire EDM: See   Beta Opticam Wire EDM on page 7.  

• Probing: See Probing on page 10.  

Major enhancements to workflow and productivity: 

• One-touch command access via custom trackball. See 

Command shortcuts via trackball RMM Customize on page 12. 

• Tool List Editor: See View/Edit Tool List on page 12. 

• 3D Material Only: See 3D Material Only on page 13. 

• Dimensioning: See Dimensioning on page 13. 

• Two-click “Mouse Shape” function: See Mouse Shape on page 14. 

• Align Face to CS, either side: See Align Face to CS on page 14. 

• Dockable panes: See Dockable Panes on page 14. 

• System-wide process changes: See page 14.  

Improvements to visualization:  

• Show clearance volume and clearance 

planes in workspace soon 

• Body Bag usability: background colors, tab locations 

• Improve visibility of plane side in 3D views 

• Selection visualization of Intermediate Tooling 

• Show/hide Intermediate Tooling toolblocks 

For details, see Enhancements to Visualization on page 15. 

Improvements to Simulation:  

• Improve axis visualization in Sim / Show Position 

• Import/export of Watches and of Stops 

• Two new standard datums: Operation CS 

and Toolgroup Home 

For details, see Enhancements to Simulation on page 16. 

Improvements to Hole Machining:  

• Predefine ANSI drill sizes by gauge letter/number 

• New context menu item (RMM): Select Hole Group 

• Two-sided hole machining improvements: Split Through Hole 

• Improve noncutting tip behavior for taps and reamers 

For details, see Enhancements to Hole Machining on page 17. 



What’s New in GibbsCAM 14 

 Page 4 of 30  last revised: 2020-09-16 at 09:44 

Improvements to Intermediate Tooling:  

• Programmable axes 

• Stacking of adapter blocks 

• Easy filtering-out of unsuitable choices 

• Show/hide Intermediate Tooling toolblocks 

For details, see Intermediate Tooling on page 18. 

Improvements to kinematics, machining, and tooling:  

• U-axis turning support 

• Support for Ceratizit’s FreeTurn tools for High Dynamic Turning (HDT) 

• Swappable heads 

• New plug-ins for Tool Libraries (Harvey, Helical Solutions, and Garr); 

and CoroPlus compatibility with GibbsCAM 14 

• For MTG (move toolgroup): Control over tool subposition soon%52978% 

• For MTG: Improve clarity of CS selection drop-down soon%% 

• Parametric lathe toolholders 

For details, see Kinematics, Machining, and Tooling on page 19. 

Improvements to DCD: 

• Clarify stock size: X Max / X Min instead of X+/X- 

• Datestamp function for part comments and 

programmer comments 

For details, see DCD on page 22. 

Improvements to posting and output: 

• G-Code Editor: Many functional improvements 

• GUI for work fixture offset (WFO)  

For details, see Posting and Output on page 23. 

Miscellaneous:  

• Double Milling (Pinch Milling) in MTM 

• Performance improvements to Pull Off Wall 

• New right-click menu option: Activate Machining CS 

• Mousewheel zoom in/out option to use “camera” 

rather than part 

• Clearance Direction in Op Data > Adv. Approach/Retract 

• Improvements to Radial Contouring and  

Radial Pocketing: Analytic Output 

• Desupport of older Windows versions 

• Performance improvements to importing using Spatial. 

• New preferences for Import/Export and Appearances. 

For details, see Miscellaneous on page 24. 

5-Axis: 

A new product option (Additive 5-Axis) and many other enhancements to 5‑Axis: See 5-Axis on page 25. 
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New Product Options 

  Beta Additive Machining (Deposition Additive) 
This major new product option for base GibbsCAM includes 
definitions of deposition additive tools (Powder and Wire), 
additive process types (Fill, Contour, and Rotary Surface), 
additive technology files, additive weave patterns, additive 
toolpath, and postprocessor support for additive operations. 

This product option is still in Beta testing phase. Do not use it in production. 

Tools: 

• Powder 

• Wire 

 

  
Additive Tools 

 

Processes: 
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Cladding 
Additive processes calculate the number of cladding layers required, using parameters from the 

integrated Technology Database. You are offered only the cladding heads supported by your machine, 

and processes present only the technology data applicable to the selected head. User parameters 

specify weave 

pattern (square, 

rectangle, ladder, 

etc.), cladding order 

(center-out, left-to-

right, etc.), and the 

rotation of cladding direction in 

each layer.  

 

Hybrid Machining 

In a single part, additive 

operations can be combined with 

subtractive operations (milling, 

turning, and broaching) to create 

true hybrid machining.  

 

 

 

GibbsCAM Integration 

Additive tools and operations are fully supported by the Tool Summary/Manager and the 

Op Summary/Manager, as well as by Reporter commands and macros. 

Postprocessing 

A single postprocessor creates all your CNC code, with no need to copy-and-splice or use 

multiple part programs. 

     ‘ Beta Additive Multiaxis Surfacing 

A new product option for 5-Axis supports deposition 

additive machining fully integrated with subtractive 

machining.  

Like the base product option, this product option is still 

in Beta testing phase. Do not use it in production. 
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  Beta Opticam Wire EDM (Electrical Discharge Machining) 
 

The previous Wire EDM product option is replaced by a new and more 

comprehensive approach using existing high-end technology that is 

integrated within GibbsCAM. Legacy Wire EDM will be supported in 

GibbsCAM 14 but not beyond. 

The new product option, Opticam, includes a detailed technology base 

that complies with all major machines providing Wire EDM machining 

capabilities.  

This product option is still in Beta testing phase. Do not use it in 

production. 

In Beta releases, Opticam starts disabled. To use it, use Plug-Ins > Plug-In 

Manager to enable “OptiCAM EDM(wire_gc_lh.dll)”. 

High-level overview 

The usual sequence is as follows:  

1. Define features, usually 

by Automated Feature Recognition, which you can adjust as 

needed for performance/precision, the features you want to 

be selected, collars and tapers, and other fine tuning).  

2. Specify the technology you want to use, and then define 

strategies such as Feature Sequence, Cut Sequence, and Bridge 

Cut.  
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3. Specify technology profiles and outputs as needed. 

As usual, you can either accept defaults or else adjust parameters as needed: 

4. The process dialog also lets you specify the usual parameters for depths and clearances, cutting 

direction, tolerances, yes/no reverse, and arc handling, as well as EDM-specific parameters like 

nozzle distances/heights and bridge parameters (size, deviation, stop distance).  

5. Actions can be combined into groups in various ways, with manipulation of features within a group 

(such as differing tapers). 

6. Render the toolpath and check it with Simulation:  
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7. Double-check and adjust as needed: 

8. Tools like the Cutting Plan streamline this process:  

9. When all is as it should be, post it.  

A post upgrade is required for the new Opticam Wire EDM product option. 
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Probing 

This new product option includes definitions 

of probing tools ( ball, disk, cylinder, 

2D Form, and 3D Form), simulation 

support, a framework for probing operations, 

and built-in probing cycles:  

o Part setup. Probing cycles during part 

setup can determine the initial setup 

locations of stock, such as by touching off a corner 

of the stock or a vice, or by probing a known 

feature on a casting. The output can be used to 

load WFOs (work fixture offsets) or other offsets on the machine.  

o In-process probing. 

Probing cycles can be added 

between cutting operations to verify that 

an operation successfully achieved the 

desired result. This can allow for fixing a 

program in case of error or for stopping 

operations when a part is scrap, thus 

providing more efficient machine use and 

less wastage.  

In cases where an operation fails, 

machines offer such response modes as:  

▪ Stop cutting and output an error code 

▪ Reload a tool 

▪ Re-execute some portion of the 

program to re-cut the part 

In-process probing is often combined with 

multi-process groups, such as:  

▪ Probing a bore 

▪ Probing a pocket depth 

▪ Probing the walls of a completed 

operation 

o On-machine inspection. This is similar to 

in-process probing but is performed after 

all operations are completed, resulting in 

a “good” or “bad” rating for the entire 

part. When the user does not need to 

unmount the part and mount it on a 

dedicated inspection, it allows for far 

greater shop efficiency. 
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License options for Probing 

All customers who purchase Probing will receive the Basic functionality. This provides the framework 

(probe tools and a basic Probing process that lets you specify depths, feedrate, cycle time, and CS). 

To create an operation, paste in G code that is passed to GibbsCAM without validation or simulation. 

If GibbsCAM.Probing.Generic.dll is enabled, Generic 

functionality is 

available for such 

functions as single 

surfaces, rectangular and circular pockets/bosses, and corners: 

•  Probe Shape (Generic) functionality provides such common 

probe cycle types as Single Surface, 

Rectangular/Circular Pocket, and Rectangular/Circular 

Boss, and it supports such result types as Set Workfixture and 

Measurement. (Measurement lets you specify separate 

responses for Undersize and Oversize result types). 

•  Corners (Generic) functionality is intended for WFO 

setup on mill-style tables. It provides such 

cycle types as Outside Corner, Outside 

Corner with Angle, and Single Surface 

from Corner (Z). You can set this to either 

Workfixture or Workplane, specify planar and 

Z clearances, and specify independent corner 

distances for X, Y, and Z. 

•  GoTo is a utility operation that lets you target an 

operation in Result > Measurement > 

Undersize or Oversize > GoTo. 

GibbsCAM Integration 

Probing tools and operations are fully supported by the Tool Summary/Manager and the 

Op Summary/Manager, as well as by Reporter commands and macros. The Probing guide contains 

detailed information on creating custom probe cycles.  

Third-Party Integration 

Custom providers (GibbsCAM partners) can provide additional probing functions in three different ways:  

• Plug-ins: The most powerful and flexible way, for experienced developers who want to write their 

own extensions to the GibbsCAM process-dialog GUI. 

• Customizable xVMM cycles: The easiest solution to implement, but somewhat limited. 

• Macros: In the Probing guide, see the chapter titled “Using Macros to Create a Custom Probe Cycle”. 

Postprocessing 

A post upgrade is required for the new Probing product option. 
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Enhancements to Workflow and Productivity 

Command shortcuts via trackball RMM Customize 

When you right-click the trackball, its context menu now 

offers a powerful new choice: Customize. 

The Trackball Customization dialog allows you to drag any command to any of the eight slots of the 

trackball, using any of eight possible combinations of key modifiers (Shift, Ctrl, and/or Alt). 

This puts up to 64 commands at your fingertips: Press F5 to summon the trackball, press up to three 

modifier keys (the trackball display changes accordingly), and click a sector of the trackball. 

 

(Sample) Plain Shift 

Plain 

  

Ctrl 

  

Alt 

  

Ctrl 

+Alt 

  
 

View/Edit Tool List 

GibbsCAM 14 provides a new 

dialog for viewing or editing a 

tool list (*.tlst) file. Tool List 

Manager lets you:  

• Hover over a tile in the dialog 

to show the Tool Preview in the hover 

window.  

• Order tools by tool type (default), by tile 

number, or by toolgroup.  

• Use the search bar to find a tool by text and/or by its most important dimension, optionally filtered 

by toolgroup.  

• Delete a tool from the tool list.  

• Drag a tool from the tool list to the part or vice versa.  
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3D Material Only 

With 3D Material-Only, material can be shared across different operation types (such as Milling and 

Turning operations) or different CS’s, and 3D milling can use rest material. It also provides Machine Sim 

with a more accurate picture. When a process dialog’s Solids tab is bolded, it can use 3D Material Only. 

Controls for Material Only are in the 5-Axis process dialog Options tab and in the Simulation dialogs, and 

three new global preferences allow you to specify how resources are used by 3D Material: 

• In the DCD, you can set a global tolerancing preference for 3D material-only. Tighter tolerances 

mean better accuracy, at the cost of larger model size. 

• In the File > Preferences dialog, Machining Prefs tab: 

You can set a new preference, Enable Background 

Material Calculation, to specify whether the 

calculation of 3D material-only runs in the 

background (faster but greedier in memory) or the 

foreground (slower but providing more control). 

• In the File > Preferences dialog, File tab: Because 

this function operates by saving extensive data for 

3D rest material, you can set a new preference to 

Save Material (keep all data for Material Only), 

independently of other file-related preferences. 

Exceptions and Limitations 

• 2D Material-Only is analytic (exact solution), whereas 3D is usually approximated to tolerances. 

Output can change between 2D and 3D during the execution of multiple operations: Some 

operations consume and produce only 2D Material; some (like Advanced 3D and Additive) only 

3D Material; some can consume either as input; a few ops can produce either as output.  

• Part flips, and part transfer from one spindle to another, require a utility op and VMM change. 

Dimensioning 
Dimensioning has changed in several important ways. 

• On-the-fly preview (mouse hover): While dimensioning, when you click the first element, 

hovering over another element causes a preview of the dimension to appear. To accept it, 

CTRL+click the candidate element and then adjust the dimension’s position as needed. 

• Additional dimensioning types: 

o  Angle to H axis 

o  Angle to V axis 

• Additional dimensioning behavior: 

A new Multiple Dimension mode lets you create multiple dimensions 

with maximum power and efficiency. In this mode, you select a dimensioning type and 

then, after you select a base feature: 

o Hovering over another feature provides a preview of the dimension;  

o CTRL+click sets the dimension; and  

o CTRL+drag adjusts the dimension’s position. 
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Mouse Shape 
The lower left corner of the most-used Geometry > 

Shape dialogs presents a new  button that lets 

you create shapes with a quick click-slide-click: 

Click to anchor, slide to get a ghosted preview, and 

then click to create the shape. 

Dockable Panes 
Many dialogs can now be docked — that is, attached to the left, bottom, right, or top side of the 

workspace or to each other (creating a tabbed window). These dialogs include: Body Bag, Program Error 

Check, CS List, Workgroup List, Operation Manager, Tool Manager, Process Manager, and a few others. 

Clicking  in a dialog’s titlebar activates the Docking Control in the workspace and in the 

center of each docked pane. Dragging the dialog onto an outward-pointing arrow (up= ,  

left= , right= , down=  ) docks it to that side, and dragging it onto the center (  ) adds a 

tab. Right-clicking the titlebar of a dialog in a tabbed pane lets you set tabs at top or bottom. 

  

Align Face to CS 
Align Face to CS now can align to either side of the CS. The first click aligns to the positive side as before, 

and the second click aligns to the negative side of the CS. 

System-wide process changes 

Combinatorial coolants 
GibbsCAM can now program custom coolants individually or in combinations, 

such as Pressure Type and On/Off Location. The interface presented to the 

user lets these values be set separately for each toolgroup or part station. 

Comments for processes 
You can now store comments with each process. When you generate operations, process comments are 

saved in the operation data, in the Op Comment field. When you open an operation, its Op Comment 

data is displayed in the Comment field of the process dialog. The Comment input text field for a process 

dialog is located at the bottom of its leftmost tab: 
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Enhancements to Visualization 

Flyout tool preview and description 

Right-click context menu item Change Tool opens the Select Tool Type flyout, which now provides a 

detailed picture of the tool along with the most salient data describing the tool. 

 

Show clearance volume and clearance planes in workspace soon 
You are better able to visualize clearance planes (or clearance volume shape when 

Clearance Volume is enabled) in the workspace. 

Improve visibility of plane side in 3D views 
The axis letters (XYZ or HVD) are now easier to see, with each letter designation fully 

displayed when edge-on but converted to a symbol (+ or –) when seen from above 

or below. This is particularly helpful for visualizing the depth axis in world view. 

Visualization of Intermediate Tooling 
Adapter Preview. Intermediate Tooling provides a preview 

of each adapter that can fit into the receptor node that 

receives it, allowing for easy visualization and selection. 

Show Fixture in Workspace. In the DCD’s Intermediate Tooling tab, 

for Fixtures, each entry in the intermediate tooling fixture table has 

a property of optionally displaying the fixture in the workspace.  

Easy setting of background color for Body Bag, 

Intermediate Tooling, and others 
Many dialogs provide easy customization of background color: 

Right-click the title bar and select View > Set Background Color. 

Body Bag tab controls 

Right-clicking a Body Bag tab provides a context menu that allows you place the tabs 

on the bottom or the top, and to set a tab’s background color.  
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Enhancements to Simulation 

Improve axis visualization in Sim / Show Position 

The Show Position dialog provides new options for finer 

control and visualization of Op Sim, Machine Sim, Tool Sim, 

and Rapid Sim. 

For easy visualization, when you press Next Feature, in 

the Rendering dialog, the Show Position dialog shows the 

axes that move by changing the color of their values and 

sliders. 

 

 

 

Import/Export of   Stops 

The Stops dialog for Op Sim, Machine Sim, Tool Sim, and Rapid Sim 

now offers new buttons that let you   import and   export 

Stops files (*.smd files). 

 

 

Import/Export of Watches 

The Watches dialog now offers new buttons that let 

you   import and   export Watches files (*.smd files). 

 

 

New Standard Datums 

In addition to all previous datums, you can now use new 

datums for Op CS (operation coordinate system) and for 

Toolgroup Home. 
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Enhancements to Hole Machining 

Predefine ANSI drills by gauge letter/number 

ANSI drills can be chosen by standard gauge size: The letter A is for 

a diameter size of 0.234 inches, B for 0.238 inches, C: 0.242", …, 

M: 0.295", …, Y  0.404", Z: 0.413". 

New context menu item (RMM): Select Hole Group 

When you right-click a selected hole, a new item appears on the context 

menu: Select Hole Group. This allows you to expand the selection by 

adding holes that belong to the same group or groups to which the 

selected hole belongs. 

Two-sided hole machining improvements: Split Through Hole 

A new ability to split a hole is provided when you edit a Through hole 

(or, in Hole Manager, when you right-click a Through hole or a group of 

Through holes, using a new context menu option), to open the 

Split Through Hole dialog.  

This dialog lets you split the Through hole at a 

segment you specify, creating one or two new 

holes and the ability to machine one hole from 

both sides. 

 

 

 

 

Improve noncutting tip behavior for taps and reamers 

Tools with non-cutting tips, such as flat-bottom reamers, now display their tips more clearly and 

accurately. 
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Intermediate Tooling 
Stacking of adapter blocks 

GibbsCAM 14 now allows stacking of toolblocks. Toolgroups can hold adapter blocks [that can hold 

other adapter blocks [that can …] that can hold toolholders.  

The machine definition specifies toolgroups and part stations; this is not subject to change. Intermediate 

Tooling lets you specify intermediate items — between toolgroup and tool, and/or between part station 

and tool; these can be changed as needed. The kinematic tree treats terminal nodes (tool stations, 

part stations, utility stations) as open receptors for either tools/parts or toolblocks. Each toolblock has a 

fitting node, where it attaches to the kinematic tree or to a receptor node, and one or more receptor 

nodes, where another object’s fitting is attached. All fittings have a type and size. Receptors specify the 

type and size of the fittings they accept. Candidate toolblocks are presented for selection only if their 

fitting node matches the receptor node; see Visualization of Intermediate Tooling on page 15. 

 

Preview in Tool dialog 
 

Programmable axes 

You can use Intermediate Tooling to 

add interpolated axes and to specify 

programmable axis status and 

behavior. This makes possible such 

features as U-axis heads, powered 

broaching units, and many others. 
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Kinematics, Machining, and Tooling 

FreeTurn tooling systems for High Dynamic Turning (HDT) 

Because of GibbsCAM’s Universal Kinematic Machine (UKM) architecture, the versatility of Intermediate 

Tooling, and its Advanced Turning enhancements, GibbsCAM 13 could already support innovations like 

Ceratizit’s FreeTurn tools for High Dynamic Turning (HDT) before those tools were available.  

For more information on FreeTurn, see https://www.ceratizit.com/en/hdt/ 

U-axis turning support 

In GibbsCAM 13, Advanced Turning provided interpolation turning, eccentric turning, 

and elliptical turning. GibbsCAM 14 supplies the next piece of Advanced Turning: 

Support for U‑axis turning (the U-axis being an 

“alternate X-axis”), where a live milling tool spins 

the cutting edge of a turning-type insert as a kind of super-

boring-bar.  

GibbsCAM 14 supports up to four linear and three rotary axes in an interpolation set.  

Swappable heads 

Entire heads can be detached and parked, and a different head attached. 

(In the MDD tree, a head is a subtree that goes extends outward to but 

does not include a tool assembly).  

The sequence is as follows (Okuma Bridge): 
 

1. 5-Axis machining with 
Head #1. 

 

https://www.ceratizit.com/en/hdt/
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2. Upon completion, 5-Axis 
tooling is retracted into 
head and Head #1 is 
stowed. 

     
3. Head #2 is fetched and 

tooling is deployed. 

       
4. U-Axis machining with 

Head #2. 
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Parametric lathe toolholders  

GibbsCAM 14 Turning users are no longer confined to the toolholder database. You can define custom 

lathe toolholder profiles by providing values for a few key dimensions provided in the Tool dialog under 

Custom > Type=Parametric, just as for parametric holders for milling tools. If you enter values that are 

impossible or grossly disproportionate, the pull-down menu defaults back to Other. 

For lathe toolholders requiring 

other dimensions, Profile is still 

required. Parametric is not 

supported for ATC style holders, 

for laydown-style (LT) thread 

inserts, or for form tools.  

The set of holder parameters to 

be defined varies according to 

insert type (ISO acute/obtuse or 

groove-style), insert flank angles, 

and insert flank length, as well as 

overall tool length, head length, 

and (for groove-style) max depth. 

Tip profiles and shank profiles 

have separate sets of parameters, and the connection between tip and shank varies according to back-

cutting or front-cutting. 
 

Plug-Ins for Harvey Tools, Helical Solutions, and Garr Tools 

Three new plug-ins provide easy access to every tool in the Harvey Tool 

Library, Helical Solutions tool library, and (soon) Garr Tool Library. You simply 

enter your filter criteria, narrow down the list to a manageable size, and then 

import all the tools you need. They will then be visible within GibbsCAM. 
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Plug-In for CoroPlus 

Enhancements to make CoroPlus compatible with GibbsCAM 14. 

For MTG (move toolgroup): Control over tool subposition soon%52978% 

The utility process dialog for Move Toolgroup now offers choices of subpositions. 

For MTG: Improve clarity of CS selection drop-down soon%% 

When the utility process dialog for Move Toolgroup offers several CS selections, it is now clearer which 

CS is associated with which spindle / part station. 

DCD 

Datestamp function for comments 

Users can now easily insert a date/timestamp on their DCD comments.  

 

 

 

 

 

Clarify stock size 

For greater clarity, labels on stock are changed from– and + 

(such as X–, X+) to Min and Max.  
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Posting and Output 
G-Code Editor 
The G-Code Editor now provides extensive 

find and replace capabilities, and its Find 

Results pane provides options like 

Go to result, Next, and Prev. 

Its List pane can now show: 

• An Operation List pane that provides 

a list of operations by line. 

• A Called Tools List pane that provides 

a list of tool calls by line, plus G-Code. 

• A Program List pane that provides a 

list of program codes by line, plus G-Code. 

You can also set the background color, and you can print results in either black-and-

white or color. 

Add G-Code Utility Process 

Add G-Code, formerly a plug-in, is now a utility process.  

GUI for work fixture offset (WFO) 

Before GibbsCAM 14, users assigned up to one work fixture offset 

(WFO) to each coordinate system (CS). This constrained the use 

of WFOs, sometimes required part programmers to needlessly 

create duplicate CS’s, and did not support multi-part setups. 

In GibbsCAM 14, WFO assignments are in the Post Processor 

dialog instead of the CS list. This lets you: Identify at a glance a 

Part Station or a multi-part part instance, with markers for 

whether the WFO is manually changed ( —e.g., ), the op is 

shifted from the WFO origin ( ), op oriented differently from 

the WFO definition ( ), or any combination (e.g., ); assign a 

WFO per op rather than per CS (including multi-part instances); 

see the WFO list before you post; and tell the system how to 

handle cases where a WFO does not match a CS. If your post is 

from before GibbsCAM 12, the interface simply lists CS’s and 

WFOs. UKM posts (specifically designed for GibbsCAM 12 and later) display a new interface (pictured).  

Options in the new interface let you determine how WFOs are assigned, such as combining identical 

WFOs regardless of the source CS, allocating one WFO per part instance, or using Local Shifts instead of 

Work Shifts. 

In GibbsCAM 14, your ability to specify behavior is more powerful, and so interpretations are now 

stricter. If you have assigned CS’s with different origins to the same WFO in a previous version of 

GibbsCAM, the system automatically remaps them to different WFOs and notifies you of the changes.  

Note on posts: Some posts from before GibbsCAM 14 may need modifications to output user-specified 

WFOs for certain operation types. 
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Miscellaneous 
Double Milling (Pinch Milling) in MTM 

With double milling, you can have two milling operations 

working on opposite sides simultaneously. This is similar to 

analogous operations in pinch turning. 
‑ 

Efficiency and performance improvements 

Rough Turning using Pull Off Wall provides a new parameter (Maximum 

Pull Off Distance) that lets you specify how far back the tool will pull off. 

When this is set, changes to the toolpath algorithm provide performance 

improvements because of fewer tool change positions. 

Imports of parts using Spatial are now threaded, meaning that machines 

with multiple cores can import much faster than before. Performance is 

especially improved when importing assemblies containing many parts. 

Radial Contouring and Radial Pocketing now offer options for analytic 

output, greatly reducing the size and complexity of G-Code output. 

Changes in Preferences 

The Preferences dialog lets you set:  

• Import/Export: Import Construction Geometry  

• Display > Appearance > Colors: Colors for Additive, 

Probing, and Mouse Shape 

Also, see preferences for 3D Material Only on page 13 and for 

Activate Machining CS and Reverse Mouse Wheel Zoom below. 
 

New option: Activate Machining CS 

The context menu when you right-click an op tile provides a new option, Activate 

Machining CS, to visualize and activate that operation’s CS.  

In the File > Preferences dialog, Interface tab: You can select the 

Activate Machining CS on Op Load checkbox if you want an operation’s 

CS to be activated upon loading the operation.  

Note: Enabling this as the default behavior provides simple, fast, and 

powerful access, but it is not recommended for bottle mold or Z Ramp. 
 

Zoom using reverse mouse wheel zoom 

In the File > Preferences dialog, Interface tab: You can set a 

preference for the mouse scrollwheel behavior. Reverse Mouse 

Wheel Zoom specifies that scroll-up will pull the “camera” closer 

(showing less of the part but in greater detail) and scroll-down will 

pull the “camera” away (showing more of the part but in less detail). 
 

Desupport of Windows versions before Windows 10 or Windows Server 2019 

Although GibbsCAM 14 will run on older versions of Windows, we will no longer investigate or create 

solutions for problems specific to versions before Windows 10 or Windows Server 2019. 
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5-Axis 

Each new release of GibbsCAM includes upgrades and enhancements 

to 5-Axis. In GibbsCAM 14, additional capabilities include:  

• Support for 3D Material Only via a checkbox on the Options page.  

• Support for form tools (generic revolved tools). 

• New Surface paths calculation type: Contouring (edge trimming). 

A specialized strategy for edge trimming of thin‑walled hulls and other thin materials. 

   
 

• Multiaxis machining provides new floor and wall finishing strategies that take advantage of barrel 

tools, as well as automatic collision-free linking. 

  

  

  

  

  

  

  

  

  

 

• Gouge check tab: Auto-tilt for barrel mills (Tilt tool – Automatic > Parameters > Preference: 

Equal tilting): 
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• Tool axis control tab: Tilt by contact point:  

  

• Surface paths / Deburring: Enhanced deburring: 
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• Surface paths / Surface machining: Geodesic medial axis (Guide curves > Pattern type: {morph, 

parallel} > Input type: Medial axis): 

  

• Surface paths / Geodesic machining: Add medial axis to cuts (Corners > Medial axis):  
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• Surface paths / Geodesic machining from mesh (Guide curves  > {Input type, Containment}: 

User-defined mesh): 

  

• Multi Cuts tab for Swarf machining: Spiral cutting for closed contours (Method: Spiral): 
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• Surface paths / Swarf machining: Customize guide curve detection ([⋯] ☑Advanced > 

Machining direction: 🔘 Other direction): 

  

• Surface paths / Geodesic machining: Autodetection and advanced options for guide curves: 
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• Toolpath smoothing with corner rounding: Sharp corners are replaced by splines. 

 

 

• Support for automated contouring (edge-trimming) on thin workpieces. 

 

• Enhancements to deburring (lead/lag angles, climb/conventional machining directions). 

• New tilting option (Side tilt by contact point) and automatic tilting for barrel mills. 

• Additional options to round corners in small-radius areas, avoiding fishtail or dovetail toolpath. 

… along with many others. 
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